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Experiment No: 1 

AIM: To identify different components of computer. 

THEORY:  
Computer: A computer is a programmable electronic device that accepts raw data as 
input and processes it with a set of instructions (a program) to produce the result as 
output. It renders output just after performing mathematical and logical operations and 
can save the output for future use. It can process numerical as well as non-numerical 
calculations. The term "computer" is derived from the Latin word "computer" which 
means to calculate. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

Identification of Different Components of Computer  

 

❖ Keyboard : A keyboard is one of the primary input devices used with a computer. 

Similar to an electric typewriter, a keyboard is composed of buttons used to create 

letters, numbers, and symbols, and perform additional functions. 

❖ Mouse : It is a handheld hardware input device that controls a cursor in a GUI 

(graphical user interface) and can move and select text, icons, files, and folders on 

our computer. 

❖ Monitor : A monitor is an electronic output device that is also known as a video 

display terminal (VDT). It is used to display images, text, video, and graphics 

information generated by a connected computer via a computer's video card. 

Although it is almost like a TV, its resolution is much higher than a TV. 

❖ Motherboard : It is a computer’s central communication backbone connectivity 

point, through which all components and external peripherals connect. It’s an 

interface between CPU and hard-drive. 

❖ Speaker : It is an output hardware device that connects to a computer to generate 

sound. The signal used to produce the sound that comes from a computer speaker 

is created by the computer's sound card. 

 

Fig. 1.1: Various components of computer. 
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Experiment No: 2 

AIM: To understand elements of windows operating system. 

THEORY: 

Operating System: It is a type of system software that acts as an interface between the 
users of a computer and the computer hardware. It acts as the resource manager that use 
the computer resources like CPU, memory, files and I/O devices in an efficient manner. 
Example: MS DOS, MS Windows, Unix etc. There are various versions of MS Windows 
available like Windows XP, Vista, 7,8 or 10. 
 
Basic Components of Windows  

Window: A window is a area of desktop within which all widows based program run.  
 
Desktop: Desktop refers to main background area. We can customize desktop in various ways 
such as editing background pictures, changing background colour and changing the icons on the 
desktop. There are small pictures which appear on the left side of the desktop called icon. We 
choose are of the icon by double clicking on it.  
 
Taskbar: The taskbar is a simple row at the very bottom of the screen where all currently opened 
files or applications are listed. It helps you select what you want to keep opened and what you 
want to close.  
 
Start Menu: By clicking the start menu, in the bottom left corner of the screen, a vertical window 
consisting of the recently opened applications and saved locations will pop-up.  
 
My computer: It provides a quick access to our computer disk device. Control panel and internal 
devices.  
 
My document: It provides a complete space to store our document.  
 
Recycle bin: It stores all the information of all the deleted files and folder. It also allows us to 
recover them.  
 
Network place: It allows us to view or display various network available and files and folders on 
our network.  
 
Maximize/Minimize/Close Buttons:  
These buttons are located at the top right corner of our opened documents, and the area used to 
close, minimize or maximize the document window. They help us jump from one task to another 
fast and let us decide either we want to close an application or resize it‘s area on the screen or 
just hide it for a few moments.  
 
WINDOWS UTILITIES & ACCESSORIES  
                    In Windows 10 we still have well-known Windows Accessories folder. Use 
       Start Menu ---> All Apps ---> Windows Accessories.  
1.Note pad: It is a simple text editor for Microsoft windows. It is a common text only editor        
which have no format tags or styles. The extension name is .TXT  
2.Word pad: It is a basic word processor. It is more advanced then note pad but less efficient then 
Microsoft word. The extension name is .DOC.  
3. Paint: It is a drawing tool. The extension name is .BMP  
4. Calculator: It is commonly used icon calculating tools in window OS.  
5. Sound recorder: It record sound and save it in the computer. 
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WINDOWS KEYBOARD SHORTCUTS  

Keyboard shortcuts are key commands that allow you to accomplish various tasks. 
Instead of using the mouse to go through menus and sub-menus, we can use keyboard 
shortcuts to do common tasks like saving, copying, or pasting. Listed below are some of 
the most common keyboard shortcuts.  
 
Serial Number  Keyboard Shortcuts  Operations they 

perform  
1.  CTRL+W  Close  
2.  CTRL+C  Copy  
3.  CTRL+X  Cut  
4.  DEL  Delete  
5.  ESC  Exit  
6.  CTRL+ALT+DELETE  Reboot/Restart  
7.  CTRL+S  Save  
8.  F1  Help  
9.  Windows Key* + M  Minimize Window  
10.  CTRL+DEL  Move to Recycling  
11.  CTRL+N  Create a New file  
12.  CTRL+O  Open a file  
13.  Windows Key*  Open Start Menu  
14.  CTRL+V  Paste  
15.  CTRL+Y  Redo an operation  

 
 
 

 

 

 

 

Fig. 2.1: Various components of Win 10 desktop screen. 
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Experiment No: 3 

AIM: To draft a basic Curriculum Vitae (CV) for an interview using tables, footer and  

            headings with following specifications: 

❖ Table to show qualifications with heading. 
❖ Left & Right margins 
❖ Page numbers in the footer on the right side. 
❖ Use watermark such as biodata. 

 

ALGORITHM: 
 

Step 1: Open a blank document. 

Step 2: Type a Bio-data briefly then goto Insert → Table→Insert→Table→Select 

                number of rows & columns→Ok for qualifications. 

Step 3: Go to Page Layout→Margins→Assign→Left & Right Margins 

Step 4: Go to Insert →Page Numbers→Select footer on the right side→Ok. 

Step 5: Go to Page Layout→Watermark→Customize text as Bio-data→Ok. 

Step 6: Save the Document. 

OUTPUT: 

 
 
 

RESULT:   

  Thus, the curriculum vitae (CV) has been created with some specifications 
in Microsoft word successfully. 

Fig. 3.1: The CV format on MS Word. 
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Experiment No: 4 

AIM: To create a WORD document to call letters for an interview using mail merge. 
 

ALGORITHM: 

Step 1: Open a blank document 

Step 2: Goto Mailings in Menu → Start Mail merge →Letters 

Step 3: Type a interview call letter with FROM address and leave some 

                Space for TO address 

Step 4: Goto →Select recipients → Type a new list →Customize the 

                Columns →Ok 

Step 5: Type a 10 address new some fields →Ok →save it 

Step 6: Goto  → Select recipients → Use Existing list →open a file →Ok 

Step 7: Under the TO Address insert the Merge fields & preview the results 

Step 8: Goto Finish Merge →Edit individual Documents → All →Ok 

Step 9: Save the document. 

OUTPUT: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

RESULT:   

  Thus, the Mail Merge has been created in Microsoft word successfully. 
 

Fig. 4.1: The Mail Merge for 10 candidates on MS Word. 
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Experiment No: 5 

AIM: To create an EXCEL spreadsheet to analyse the marks of the students of a class   

____using various chart (Line, XY, Bar and Pie). 

ALGORITHM: 

Step 1:. Open a Microsoft Excel Worksheet. 

Step 2: Place the Cursor on the desired cell and start entering the required 

               Student details 

Step 3: To find the Total and Average using formula (Total = m1+m2+m3) 

                Average = (Total / 3) 

Step 4: Select the table and goto Insert → Chart → Choose one type of chart 

Step 5: Reselect the table again and Insert →Chart  → Choose another 

                type of Chart. Repeat these steps for all types of charts. 

OUTPUT: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

RESULT:  

                      Thus, the spreadsheet charts (Line, XY, Bar and Pie) for students’ marks      
have been created successfully. 
 
 
 
 

Fig. 5.1: The use of chart in MS Excel. 
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Experiment No: 6 

AIM: To create a spreadsheet to calculate HRA, DA, TA, PF, LIC. Gross salary, Net Salary   

____from the given data. 

HRA=18% of basic Pay, TA=12% of Basic Pay, DA=15% of Basic Pay 

PF =10% of Basic Pay, LIC =7% of Basic Pay, Deduction= PF + LIC 

Gross Salary = Basic Pay + HRA + DA + TA, Net Salary = Gross Salary – Deduction 

ALGORITHM: 

Step 1. Open a Microsoft Excel Worksheet 

Step 2. Type the details about the employees and Basic Salary. 

Step 3. For HRA & DA, move to corresponding row & column and assign the 

               formula =18/100* BS (row & column)  

  For DA , move to corresponding row & column and assign the formula  

  =15/100* BS (row & column) 

. Step 4. For TA & PF, move to corresponding row & column and assign the formula 

             =12/100* BS (row & column)  

  For PF , move to corresponding row & column and assign the formula   

  =10/100* BS (row & column) 

Step 5. For LIC & GS, move to corresponding row & column and assign the formula 

              =7/100* BS,  

  For GS, move to corresponding row & column and assign the formula   

  = Basic Pay + HRA + DA + TA 

Step 6. Likewise for Deduction and Net Salary 

Step 7. Save the Excel spreadsheet. 
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OUTPUT:  

 
 
 
RESULT:  

 Thus, the spreadsheet to calculate HRA, DA, TA, PF, LIC. Gross Salary, Net salary 
from the given data has been created successfully. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

Fig. 6.1: The use of formula in MS Excel. 
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Experiment No: 7 

AIM: To create an introductory presentation with one slide about climate change.   

ALGORITHM: 

Step 1. Open a blank slide on Microsoft PowerPoint. 

Step 2. Download prerequisite images and save it in pictures folder. 

Step 3. Go to Home tab → New slide to add blank slide. 

Step 4. Go to Insert tab → Click on Text Box and place it at heading of slide. 

Step 5. Left-click once inside the text box and start entering your text. 

Step 6. Select text inside text box. Use the Font Group on the Home tab or right- 

 click on the selected text and choose formatting options from the Mini Toolbar. 

Step 7. For inserting images, go to Insert tab → Click Pictures → This device  
               → add the required image. 
Step 8. Adjust the image size and align it with margin of page. 

Step 9. Save the MS Presentation document with suitable file name. 
 

OUTPUT : 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

RESULT:  

 Thus, a Presentation on climate change has been created successfully. 
 

Fig. 7.1: A slide on climate change in MS PowerPoint. 
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Experiment No: 8 

AIM: To insert animation on a sample presentation on renewable energy types. 

ALGORITHM: 

Step 1. Open a blank slide on Microsoft PowerPoint. 

Step 2. Download prerequisite images and save it in pictures folder. 

Step 3. Go to Home tab → New slide to add blank slide. 

Step 4. Go to Insert tab → Click on Text Box and place it at heading of slide. 

Step 5. Left-click once inside the text box and start entering your text. 

Step 6. Select text inside text box. Use the Font Group on the Home tab or right- 

 click on the selected text and choose formatting options from the Mini Toolbar. 

Step 7. For inserting images, go to Insert tab → Click Pictures → This device  

               → add the required image. 

Step 8. Adjust the image size and align it with margin of page. 

Step 9. Click on one image at a time for adding animation to it. 

Step 10. Go to Animation tab → Add animation → Click on Effects. 

Step 11. Repeat step 10 for all the text and images. 

Step 12. Save the MS Presentation document with suitable file name. 
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OUTPUT : 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

RESULT:  

 Thus, a Presentation on types of renewable energy has been created successfully. 
             
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 8.1: A slide on renewable energy types in MS PowerPoint. 
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Experiment No: 9 

AIM: To use E-mail for sending and receiving messages along with attaching a file. 
 

ALGORITHM: 

Step 1. Open any web browser like Chrome or Mozilla. 

 Step 2. Enter URL → www.gmail.com to use Google’s free email service. 

 Step 3. Login to your account using valid e-mail & password. (Fig. 9.1) 

 Step 4. In order to draft new message, click on compose button. (Fig. 9.2) 

 Step 5. Fill the To and From section which tells about receiver & sender of  

 e-mail respectively. (Fig. 9.3) 

 Step 6. Write about the subject of the e-mail (Fig. 9.3 in the region no.3). 

 Step 7. Write main body of the e-mail (Fig. 9.3 in the region no.4).  

 Step 8. In order to attach any file use label no. 6 option (Fig. 9.3). 

 Step 9. Properly check the format of the e-mail → click Send (See Fig. 9.3). 

 Step 10. In order to read newly received message, click on the Primary tab  

  (See Fig. 9.2). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig. 9.1: Login page of G-mail account. 

http://www.gmail.com/
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RESULT:  

 Thus, an e-mail has been drafted successfully along with attaching a file. 
 

 

 

Fig. 9.2: After login, various tabs and compose options are accessible. 

Fig. 9.3: E-mail writing space showing space for sender, receiver, 

subject and main body. 
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Experiment No: 10 

AIM: To install and configure antivirus / firewall on computer system. 

ALGORITHM: 

Step 1. Open the antivirus software .exe file (from CD drive or Internet). 

Step 2. Windows OS will automatically detect new software launch. 

Step 3. Select a preferred location for file, preferably C drive in My Computer. 

Step 4. Select suitable configuration and press next and install. 

Step 5. In order to configure firewall for connection authorization, open server 

      manager, select Configuration\Windows Firewall With advanced  

      Security\Inbound Rules or Configuration\Windows Firewall with  

      Advanced Security\Outbound Rules. 

   Step 6. In the details pane, right click the rule you want to configure. 

    Step 7. Click the General tab. Select Allow Only Secure Connections.  

   Step 8. Click the Users and Computers tab for an inbound rule. 

   Step 9. Click Add and select the groups containing the users or computer you  

      want to authorize. (See Fig 10.1) 

   Step 10. Click OK to finish the modifications in firewall settings.  

 

 

 

 

 

 

 

 

 

 

 

 

RESULT:  

 Thus, windows firewall has been configured successfully along with installing a 

antivirus software. 

 

Fig. 10.1: Windows defender / firewall dialog box. 
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Dos & Don’ts in Computer Lab 

 

 

 

 

 

 

 

 

 

 
Dos 

 
• Enter/exit lab quietly. 
• Raise your hand before asking 

any doubt. 
• Always have a clean & dry hand. 
• Touch keyboard & mouse gently. 
• Keep your work space clean. 

• Search only approved websites 

 
Don’ts 

 
• No food or drinks in the lab. 
• Do not mark on any part of 

computer. 
• Do not change any key settings 

of computer. 
• No magnets allowed in 

computer lab 
• Do not pull any cable/cord of 

any system. 

• Ask teacher before taking any 
printout. 


